introverted_mouse introverted_mouse
Bookmark

Error 400: redirect_uri_mismatch

Posted June 26th, 2022    94   1   Google Drive rclone error 400

I receive the following error

Authorization Error
Error 400: redirecturimismatch
The redirect URI in the request, urn:ietf:wg:oauth:2.0:oob, can only be used by a Client ID for native application. It is not allowed for the WEB client type. You can create a Client ID for native application at https://console.developers.google.com/apis/credentials/oauthclient
Learn more

when following this guide:

https://community.seedboxes.cc/articles/how-to-mount-a-remote-drive-to-your-seedbox

I am using "https://seedboxes.cc" as the URI. Could this be the error? I believe I saw a guide or answer with a different URI provided. I am happy to troubleshoot with someone. A quick Google search says the app doesn't apply with Google Auth 2.0. Did they make any changes since this guide? Thanks in advance : )

5 Replies

introverted_mouse
introverted_mouse
Accepted Answer

i was able to connect : ) thank you for going through googles devilish ways to figure this out for me. i couldnt click on accepted answer but for those that need help follow the last comment -

angoikonStaff about 11 hours
Accept Answer
For the record, Google has recently changed the authorization process, you now need to create a new set of credentials with "Desktop app" application type (which doesn't use a URI). You also need to download and install the most recent rclone version, both at your seedbox and at your PC.
For further information, please check our updated guide here .

NOTE: This is valid only for creating remotes in your seedbox via SSH (and by additionally using a terminal at your PC), as you can see at the above link.
Rclone mount installation via seedbucket is unaffected by Google changes, meaning you continue to use the "Web application" type (plus you need to input the URI), just like shown at the guide

now to work on the copy script : ) thank you again! great quick support!

introverted_mouse

just for those tracking - i did receive this -

As the error message suggests, create a new client ID for native application instead of web application

Then use this combination of client id and secret to add it to rclone

I was unable to find how to create a native application only the web application and select others, maybe I am missing it. I did try the TV option and provide the below error.

Authorization Error
Error 400: invalid_request

You can't sign in to this app because it doesn't comply with Google's OAuth 2.0 policy for keeping apps secure.

You can let the app developer know that this app doesn't comply with one or more Google validation rules.
Request Details
The content in this section has been provided by the app developer. This content has not been reviewed or verified by Google.
If you’re the app developer, make sure that these request details comply with Google policies.
redirect_uri: urn:ietf:wg:oauth:2.0:oob

angoikon
angoikon
Staff

You are using a wrong URI. You don't have to type the URI, you just press the copy button at step 4/5 of the rclone mount installation at seedbucket and it automatically copies it to clipboard. Then you proceed to Google console and paste it at the corresponding field.
Make sure to check the screenshots too so you know that you are in-sync with the guide.

Also, try doing the procedure in an incognito (private) window, in case you have multiple Google accounts and are already logged in to another one, different than the one you are using the credentials of.

introverted_mouse

update 2 -
my fault one - i was using brave speed reader which removed some of the guide. apologies.
second - i followed guide and screenshots and same error using the below URI. Any ideas?

https://seedbucket.seedboxes.cc/clouddriveredirect.html

He is the goal - i know placing plex media / arrs etc works as done on a previous box. i would like to use rclone to make a backup of one drive to another drive in case one has issue. hope this helps my goal. i think once i can get this connected, i believe i can follow the guide to setup the scripting. thanks in advance everyone.

angoikon
angoikon
Staff

For the record, Google has recently changed the authorization process, you now need to create a new set of credentials with "Desktop app" application type (which doesn't use a URI). You also need to download and install the most recent rclone version, both at your seedbox and at your PC.
For further information, please check our updated guide here .

NOTE: This is valid only for creating remotes in your seedbox via SSH (and by additionally using a terminal at your PC), as you can see at the above link.
Rclone mount installation via seedbucket is unaffected by Google changes, meaning you continue to use the "Web application" type (plus you need to input the URI), just like shown at the guide